using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\@ConfigField\(name\s+=\s+""(?P<name>\w+)"",\s+value\s+=\s+""(?P<value>.*)""(,\s+comment\s+=\s+\{((\s+""[^""]+"",?\s+){1,})\})?\)\s+public static (?P<type>\w+)\s+(?P<var>\w+);";
string input = @"@ConfigField(name = ""CastleSupportFunctionFeeRatio"", value = ""604800000"", comment =
{
""Support magic buff price"",
""Price = 7 day""
})
public static long castleSupportFunctionFeeRatio;";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}