const regex = /\@ConfigField\(name\s+=\s+"(?P<name>\w+)",\s+value\s+=\s+"(?P<value>.*)"(,\s+comment\s+=\s+\{((\s+"[^"]+",?\s+){1,})\})?\)\s+public static (?P<type>\w+)\s+(?P<var>\w+);/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\@ConfigField\\(name\\s+=\\s+"(?P<name>\\w+)",\\s+value\\s+=\\s+"(?P<value>.*)"(,\\s+comment\\s+=\\s+\\{((\\s+"[^"]+",?\\s+){1,})\\})?\\)\\s+public static (?P<type>\\w+)\\s+(?P<var>\\w+);', 'gmi')
const str = `@ConfigField(name = "CastleSupportFunctionFeeRatio", value = "604800000", comment =
{
"Support magic buff price",
"Price = 7 day"
})
public static long castleSupportFunctionFeeRatio;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}