import Foundation
let pattern = #"\@ConfigField\(name\s+=\s+"(?P<name>\w+)",\s+value\s+=\s+"(?P<value>.*)"(,\s+comment\s+=\s+\{((\s+"[^"]+",?\s+){1,})\})?\)\s+public static (?P<type>\w+)\s+(?P<var>\w+);"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
@ConfigField(name = "CastleSupportFunctionFeeRatio", value = "604800000", comment =
{
"Support magic buff price",
"Price = 7 day"
})
public static long castleSupportFunctionFeeRatio;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)