import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\@ConfigField\\(name\\s+=\\s+\"(?P<name>\\w+)\",\\s+value\\s+=\\s+\"(?P<value>.*)\"(,\\s+comment\\s+=\\s+\\{((\\s+\"[^\"]+\",?\\s+){1,})\\})?\\)\\s+public static (?P<type>\\w+)\\s+(?P<var>\\w+);";
final String string = "@ConfigField(name = \"CastleSupportFunctionFeeRatio\", value = \"604800000\", comment =\n"
+ " {\n"
+ " \"Support magic buff price\",\n"
+ " \"Price = 7 day\"\n"
+ " })\n"
+ " public static long castleSupportFunctionFeeRatio;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}