use strict;
my $str = '@ConfigField(name = "CastleSupportFunctionFeeRatio", value = "604800000", comment =
{
"Support magic buff price",
"Price = 7 day"
})
public static long castleSupportFunctionFeeRatio;';
my $regex = qr/\@ConfigField\(name\s+=\s+"(?P<name>\w+)",\s+value\s+=\s+"(?P<value>.*)"(,\s+comment\s+=\s+\{((\s+"[^"]+",?\s+){1,})\})?\)\s+public static (?P<type>\w+)\s+(?P<var>\w+);/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}