# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\@ConfigField\(name\s+=\s+\"(?P<name>\w+)\",\s+value\s+=\s+\"(?P<value>.*)\"(,\s+comment\s+=\s+\{((\s+\"[^\"]+\",?\s+){1,})\})?\)\s+public static (?P<type>\w+)\s+(?P<var>\w+);"
test_str = ("@ConfigField(name = \"CastleSupportFunctionFeeRatio\", value = \"604800000\", comment =\n"
" {\n"
" \"Support magic buff price\",\n"
" \"Price = 7 day\"\n"
" })\n"
" public static long castleSupportFunctionFeeRatio;")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.