// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)\@ConfigField\(name\s+=\s+"(?P<name>\w+)",\s+value\s+=\s+"(?P<value>.*)"(,\s+comment\s+=\s+\{((\s+"[^"]+",?\s+){1,})\})?\)\s+public static (?P<type>\w+)\s+(?P<var>\w+);"#).unwrap();
let string = "@ConfigField(name = \"CastleSupportFunctionFeeRatio\", value = \"604800000\", comment =
{
\"Support magic buff price\",
\"Price = 7 day\"
})
public static long castleSupportFunctionFeeRatio;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}