package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\@ConfigField\(name\s+=\s+"(?P<name>\w+)",\s+value\s+=\s+"(?P<value>.*)"(,\s+comment\s+=\s+\{((\s+"[^"]+",?\s+){1,})\})?\)\s+public static (?P<type>\w+)\s+(?P<var>\w+);`)
var str = `@ConfigField(name = "CastleSupportFunctionFeeRatio", value = "604800000", comment =
{
"Support magic buff price",
"Price = 7 day"
})
public static long castleSupportFunctionFeeRatio;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}