re = /\@ConfigField\(name\s+=\s+"(?P<name>\w+)",\s+value\s+=\s+"(?P<value>.*)"(,\s+comment\s+=\s+\{((\s+"[^"]+",?\s+){1,})\})?\)\s+public static (?P<type>\w+)\s+(?P<var>\w+);/mi
str = '@ConfigField(name = "CastleSupportFunctionFeeRatio", value = "604800000", comment =
{
"Support magic buff price",
"Price = 7 day"
})
public static long castleSupportFunctionFeeRatio;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end