# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/###(?:[^,]*,){8}\K([\s\S]*?)(?=,[^,]*,[^,]*###)/"\1"/g;t' <<< " ###element1,element2,element3,element4,element5,element6,element7,element8, \"element9,
element9,\"\"element9\"\",element9,
element9,element9,\"\"element9\",element10,
###
###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,
BLAHBLAH,
BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH,
\"BLAHBLAH\"\"\",E,
###"