import Foundation
let pattern = ####"###(?:[^,]*,){8}\K([\s\S]*?)(?=,[^,]*,[^,]*###)"####
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ####"""
###element1,element2,element3,element4,element5,element6,element7,element8, "element9,
element9,""element9"",element9,
element9,element9,""element9",element10,
###
###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,
BLAHBLAH,
BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH,
"BLAHBLAH""",E,
###
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""\1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)