# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"###(?:[^,]*,){8}\K([\s\S]*?)(?=,[^,]*,[^,]*###)"
test_str = (" ###element1,element2,element3,element4,element5,element6,element7,element8, \"element9,\n"
"element9,\"\"element9\"\",element9,\n"
"element9,element9,\"\"element9\",element10,\n"
"###\n\n"
"###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,\n"
"BLAHBLAH,\n"
"BLAHBLAH,\n"
"BLAHBLAH, BLAHBLAH,\n"
"BLAHBLAH, BLAHBLAH,\n"
"BLAHBLAH,\n"
"\"BLAHBLAH\"\"\",E,\n"
"###")
subst = "\"\\1\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.