use strict;
my $str = ' ###element1,element2,element3,element4,element5,element6,element7,element8, "element9,
element9,""element9"",element9,
element9,element9,""element9",element10,
###
###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,
BLAHBLAH,
BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH,
"BLAHBLAH""",E,
###';
my $regex = qr/###(?:[^,]*,){8}\K([\s\S]*?)(?=,[^,]*,[^,]*###)/p;
my $subst = '"\\1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";