const regex = /###(?:[^,]*,){8}\K([\s\S]*?)(?=,[^,]*,[^,]*###)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('###(?:[^,]*,){8}\\K([\\s\\S]*?)(?=,[^,]*,[^,]*###)', 'g')
const str = ` ###element1,element2,element3,element4,element5,element6,element7,element8, "element9,
element9,""element9"",element9,
element9,element9,""element9",element10,
###
###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,
BLAHBLAH,
BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH,
"BLAHBLAH""",E,
###`;
const subst = `"\1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);