#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "###(?:[^,]*,){8}\K([\s\S]*?)(?=,[^,]*,[^,]*###)"
Local $sString = " ###element1,element2,element3,element4,element5,element6,element7,element8, "element9," & @CRLF & _
"element9,""element9"",element9," & @CRLF & _
"element9,element9,""element9",element10," & @CRLF & _
"###" & @CRLF & _
"" & @CRLF & _
"###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH," & @CRLF & _
"BLAHBLAH," & @CRLF & _
"BLAHBLAH," & @CRLF & _
"BLAHBLAH, BLAHBLAH," & @CRLF & _
"BLAHBLAH, BLAHBLAH," & @CRLF & _
"BLAHBLAH," & @CRLF & _
""BLAHBLAH""",E," & @CRLF & _
"###"
Local $sSubst = ""\1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)