import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "###(?:[^,]*,){8}\\K([\\s\\S]*?)(?=,[^,]*,[^,]*###)";
final String string = " ###element1,element2,element3,element4,element5,element6,element7,element8, \"element9,\n"
+ "element9,\"\"element9\"\",element9,\n"
+ "element9,element9,\"\"element9\",element10,\n"
+ "###\n\n"
+ "###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,\n"
+ "BLAHBLAH,\n"
+ "BLAHBLAH,\n"
+ "BLAHBLAH, BLAHBLAH,\n"
+ "BLAHBLAH, BLAHBLAH,\n"
+ "BLAHBLAH,\n"
+ "\"BLAHBLAH\"\"\",E,\n"
+ "###";
final String subst = "\"\\1\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}