$re = '/###(?:[^,]*,){8}\K([\s\S]*?)(?=,[^,]*,[^,]*###)/';
$str = ' ###element1,element2,element3,element4,element5,element6,element7,element8, "element9,
element9,""element9"",element9,
element9,element9,""element9",element10,
###
###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,
BLAHBLAH,
BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH,
"BLAHBLAH""",E,
###';
$subst = "\"\1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;