using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"###(?:[^,]*,){8}\K([\s\S]*?)(?=,[^,]*,[^,]*###)";
string substitution = @"""\1""";
string input = @" ###element1,element2,element3,element4,element5,element6,element7,element8, ""element9,
element9,""element9"",element9,
element9,element9,""element9"",element10,
###
###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,
BLAHBLAH,
BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH,
""BLAHBLAH"""",E,
###";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}