# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/xmlAttributeReplace="([^" ]+)"/$1/g;t' <<< "<autoUnlockSection xmlAttributeReplace=\"#{token.variable.sample}\"
xdt:Transform=\"Replace\"/>"