import Foundation
let pattern = #"xmlAttributeReplace="([^" ]+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<autoUnlockSection xmlAttributeReplace="#{token.variable.sample}"
xdt:Transform="Replace"/>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)