using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"xmlAttributeReplace=""([^"" ]+)""";
string substitution = @"$1";
string input = @"<autoUnlockSection xmlAttributeReplace=""#{token.variable.sample}""
xdt:Transform=""Replace""/>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}