const regex = /xmlAttributeReplace="([^" ]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('xmlAttributeReplace="([^" ]+)"', 'g')
const str = `<autoUnlockSection xmlAttributeReplace="#{token.variable.sample}"
xdt:Transform="Replace"/>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);