$re = '/xmlAttributeReplace="([^" ]+)"/';
$str = '<autoUnlockSection xmlAttributeReplace="#{token.variable.sample}"
xdt:Transform="Replace"/>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;