re = /xmlAttributeReplace="([^" ]+)"/
str = '<autoUnlockSection xmlAttributeReplace="#{token.variable.sample}"
xdt:Transform="Replace"/>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result