// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"xmlAttributeReplace="([^" ]+)""#).unwrap();
let string = "<autoUnlockSection xmlAttributeReplace=\"#{token.variable.sample}\"
xdt:Transform=\"Replace\"/>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}