# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/String|\b(\w*?ring\w*)\b//gim;t' <<< "String bellsringing = \"The bells are ringing is a String\";"