using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"String|\b(\w*?ring\w*)\b";
string substitution = @"";
string input = @"String bellsringing = ""The bells are ringing is a String"";";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}