package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)String|\b(\w*?ring\w*)\b`)
var str = `String bellsringing = "The bells are ringing is a String";`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}