import re
regex = re.compile(r"String|\b(\w*?ring\w*)\b", flags=re.IGNORECASE | re.MULTILINE)
test_str = "String bellsringing = \"The bells are ringing is a String\";"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)