$re = '/String|\b(\w*?ring\w*)\b/im';
$str = 'String bellsringing = "The bells are ringing is a String";';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;