use strict;
my $str = 'String bellsringing = "The bells are ringing is a String";';
my $regex = qr/String|\b(\w*?ring\w*)\b/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";