// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)String|\b(\w*?ring\w*)\b").unwrap();
let string = "String bellsringing = \"The bells are ringing is a String\";";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}