#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""(.+)T.+"\s.+q=(.+)"
Local $sString = ""2016-05-22T18:10:36+09:00" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")