$re = '/"(.+)T.+"\s.+q=(.+)/';
$str = '"2016-05-22T18:10:36+09:00" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);