package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(.+)T.+"\s.+q=(.+)`)
var str = `"2016-05-22T18:10:36+09:00" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}