re = /"(.+)T.+"\s.+q=(.+)/
str = '"2016-05-22T18:10:36+09:00" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30'
# Print the match result
str.match(re) do |match|
puts match.to_s
end