import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "\"(.+)T.+\"\\s.+q=(.+)";
        final String string = "\"2016-05-22T18:10:36+09:00\" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        if (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}