// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(.+)T.+"\s.+q=(.+)"#).unwrap();
let string = "\"2016-05-22T18:10:36+09:00\" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}