const regex = new RegExp('"(.+)T.+"\\s.+q=(.+)', '')
const str = `"2016-05-22T18:10:36+09:00" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}