using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(.+)T.+""\s.+q=(.+)";
string input = @"""2016-05-22T18:10:36+09:00"" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}