import Foundation
let pattern = #""(.+)T.+"\s.+q=(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""2016-05-22T18:10:36+09:00" /c/search/unified?q=%EB%B8%94%EB%9D%BD%EB%B9%84&p=1&c=30"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}