# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"(.*my.website.*myfile)"//;t' <<< "<a class=\"URL\" href=\"http://my.website.com/a/b/cdefghijklmnopqrstuvwxyz/myfile\" target=\"_blank\">"