import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(.*my.website.*myfile)\"";
final String string = "<a class=\"URL\" href=\"http://my.website.com/a/b/cdefghijklmnopqrstuvwxyz/myfile\" target=\"_blank\">";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}