use strict;
my $str = '<a class="URL" href="http://my.website.com/a/b/cdefghijklmnopqrstuvwxyz/myfile" target="_blank">';
my $regex = qr/"(.*my.website.*myfile)"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";