using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(.*my.website.*myfile)""";
string substitution = @"";
string input = @"<a class=""URL"" href=""http://my.website.com/a/b/cdefghijklmnopqrstuvwxyz/myfile"" target=""_blank"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}