// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(.*my.website.*myfile)""#).unwrap();
let string = "<a class=\"URL\" href=\"http://my.website.com/a/b/cdefghijklmnopqrstuvwxyz/myfile\" target=\"_blank\">";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}