const regex = /"(.*my.website.*myfile)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(.*my.website.*myfile)"', '')
const str = `<a class="URL" href="http://my.website.com/a/b/cdefghijklmnopqrstuvwxyz/myfile" target="_blank">`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);