#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*(\d{4})"
Local $sString = "ABC123456789A9876" & @CRLF & _
"ABCD1234567890F23" & @CRLF & _
"1234ABC4567JIJLMN" & @CRLF & _
"ABCDEFG1234-!.567" & @CRLF & _
"12345660703J1A501F4Z2051" & @CRLF & _
"1234ABCLDlZd1523" & @CRLF & _
"1234ABCLDlZd15" & @CRLF & _
"ABC1234" & @CRLF & _
"ABC1234ABC1234A" & @CRLF & _
"ABC123ABC123A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")