// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*(\d{4})").unwrap();
let string = "ABC123456789A9876
ABCD1234567890F23
1234ABC4567JIJLMN
ABCDEFG1234-!.567
12345660703J1A501F4Z2051
1234ABCLDlZd1523
1234ABCLDlZd15
ABC1234
ABC1234ABC1234A
ABC123ABC123A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}