import re
regex = re.compile(r".*(\d{4})", flags=re.MULTILINE)
test_str = ("ABC123456789A9876\n"
"ABCD1234567890F23\n"
"1234ABC4567JIJLMN\n"
"ABCDEFG1234-!.567\n"
"12345660703J1A501F4Z2051\n"
"1234ABCLDlZd1523\n"
"1234ABCLDlZd15\n"
"ABC1234\n"
"ABC1234ABC1234A\n"
"ABC123ABC123A")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")